summaryrefslogtreecommitdiffstats
path: root/lass/1systems/uriel.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/uriel.nix')
-rw-r--r--lass/1systems/uriel.nix45
1 files changed, 31 insertions, 14 deletions
diff --git a/lass/1systems/uriel.nix b/lass/1systems/uriel.nix
index 16c39280..aa5286ae 100644
--- a/lass/1systems/uriel.nix
+++ b/lass/1systems/uriel.nix
@@ -1,33 +1,45 @@
{ config, pkgs, ... }:
with builtins;
+with config.krebs.lib;
{
imports = [
../.
../2configs/retiolum.nix
- ../2configs/baseX.nix
../2configs/exim-retiolum.nix
- ../2configs/browsers.nix
- ../2configs/games.nix
- ../2configs/pass.nix
- ../2configs/bird.nix
- ../2configs/git.nix
- ../2configs/chromium-patched.nix
- ../2configs/bitlbee.nix
- ../2configs/weechat.nix
- ../2configs/skype.nix
{
- lass.umts = {
+ # locke config
+ time.timeZone = "Europe/Berlin";
+ services.xserver.enable = true;
+ users.users.locke = {
+ uid = genid "locke";
+ home = "/home/locke";
+ group = "users";
+ createHome = true;
+ extraGroups = [
+ "audio"
+ "networkmanager"
+ ];
+ useDefaultShell = true;
+ };
+ networking.networkmanager.enable = true;
+ hardware.pulseaudio = {
+ enable = true;
+ systemWide = true;
+ };
+ environment.systemPackages = with pkgs; [
+ firefox
+ hexchat
+ networkmanagerapplet
+ ];
+ services.xserver.desktopManager.xfce = {
enable = true;
- modem = "/dev/serial/by-id/usb-HUAWEI_Technologies_HUAWEI_Mobile-if00-port0";
};
}
];
krebs.build.host = config.krebs.hosts.uriel;
- networking.wireless.enable = true;
-
hardware.enableAllFirmware = true;
nixpkgs.config.allowUnfree = true;
@@ -62,6 +74,11 @@ with builtins;
"/boot" = {
device = "/dev/sda1";
};
+ "/tmp" = {
+ device = "tmpfs";
+ fsType = "tmpfs";
+ options = ["nosuid" "nodev" "noatime"];
+ };
};
services.udev.extraRules = ''