summaryrefslogtreecommitdiffstats
path: root/lass/1systems/mors.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/mors.nix')
-rw-r--r--lass/1systems/mors.nix15
1 files changed, 4 insertions, 11 deletions
diff --git a/lass/1systems/mors.nix b/lass/1systems/mors.nix
index b7291a8f..414afcbb 100644
--- a/lass/1systems/mors.nix
+++ b/lass/1systems/mors.nix
@@ -23,6 +23,7 @@
../2configs/wordpress.nix
../2configs/bitlbee.nix
../2configs/firefoxPatched.nix
+ ../2configs/realwallpaper.nix
];
krebs.build = {
@@ -174,7 +175,9 @@
environment.systemPackages = with pkgs; [
cac
+ sshpass
get
+ genid
];
#TODO: fix this shit
@@ -195,21 +198,11 @@
};
};
- networking.firewall = {
- allowPing = true;
- allowedTCPPorts = [
- 8000
- ];
- allowedUDPPorts = [
- 67
- ];
- };
-
services.mongodb = {
enable = true;
};
- lass.iptables = {
+ krebs.iptables = {
tables = {
filter.INPUT.rules = [
{ predicate = "-p tcp --dport 8000"; target = "ACCEPT"; precedence = 9001; }