summaryrefslogtreecommitdiffstats
path: root/lass/1systems/echelon.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/echelon.nix')
-rw-r--r--lass/1systems/echelon.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/lass/1systems/echelon.nix b/lass/1systems/echelon.nix
new file mode 100644
index 00000000..92976366
--- /dev/null
+++ b/lass/1systems/echelon.nix
@@ -0,0 +1,45 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (import ../4lib { inherit pkgs lib; }) getDefaultGateway;
+ inherit (lib) head;
+
+ ip = (head config.krebs.hosts.echelon.nets.internet.addrs4);
+in {
+ imports = [
+ ../../tv/2configs/CAC-Developer-2.nix
+ ../../tv/2configs/CAC-CentOS-7-64bit.nix
+ ../2configs/base.nix
+ ../2configs/retiolum.nix
+ {
+ networking.interfaces.enp2s1.ip4 = [
+ {
+ address = ip;
+ prefixLength = 24;
+ }
+ ];
+ networking.defaultGateway = getDefaultGateway ip;
+ networking.nameservers = [
+ "8.8.8.8"
+ ];
+
+ }
+ ];
+
+ krebs.build = {
+ user = config.krebs.users.lass;
+ target = "root@${ip}";
+ host = config.krebs.hosts.echelon;
+ deps = {
+ secrets = {
+ url = "/home/lass/secrets/${config.krebs.build.host.name}";
+ };
+ stockholm = {
+ url = toString ../..;
+ };
+ };
+ };
+
+ networking.hostName = "echelon";
+
+}