summaryrefslogtreecommitdiffstats
path: root/lass/1systems/echelon.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/echelon.nix')
-rw-r--r--lass/1systems/echelon.nix33
1 files changed, 15 insertions, 18 deletions
diff --git a/lass/1systems/echelon.nix b/lass/1systems/echelon.nix
index feaf77ef..94c793b0 100644
--- a/lass/1systems/echelon.nix
+++ b/lass/1systems/echelon.nix
@@ -31,26 +31,23 @@ in {
}
{
- nix.maxJobs = 1;
sound.enable = false;
}
- ];
-
- krebs.build = {
- user = config.krebs.users.lass;
- host = config.krebs.hosts.echelon;
- source = {
- dir.secrets = {
- host = config.krebs.hosts.mors;
- path = "/home/lass/secrets/${config.krebs.build.host.name}";
- };
- dir.stockholm = {
- host = config.krebs.hosts.mors;
- path = "/home/lass/dev/stockholm";
+ {
+ imports = [
+ ../3modules/dnsmasq.nix
+ ];
+ lass.dnsmasq = {
+ enable = true;
+ config = ''
+ interface=retiolum
+ '';
};
- };
- };
-
- networking.hostName = config.krebs.build.host.name;
+ krebs.iptables.tables.filter.INPUT.rules = [
+ { predicate = "-i retiolum -p udp --dport 53"; target = "ACCEPT"; }
+ ];
+ }
+ ];
+ krebs.build.host = config.krebs.hosts.echelon;
}