summaryrefslogtreecommitdiffstats
path: root/lass/1systems/cloudkrebs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/1systems/cloudkrebs.nix')
-rw-r--r--lass/1systems/cloudkrebs.nix19
1 files changed, 15 insertions, 4 deletions
diff --git a/lass/1systems/cloudkrebs.nix b/lass/1systems/cloudkrebs.nix
index 5235c25e..2a6a70ff 100644
--- a/lass/1systems/cloudkrebs.nix
+++ b/lass/1systems/cloudkrebs.nix
@@ -1,6 +1,12 @@
-{ config, pkgs, ... }:
+{ config, lib, pkgs, ... }:
-{
+let
+ inherit (import ../4lib { inherit pkgs lib; }) getDefaultGateway;
+ inherit (lib) head;
+
+ ip = (head config.krebs.build.host.nets.internet.addrs4);
+ r_ip = (head config.krebs.build.host.nets.retiolum.addrs4);
+in {
imports = [
../../tv/2configs/CAC-Developer-2.nix
../../tv/2configs/CAC-CentOS-7-64bit.nix
@@ -8,14 +14,15 @@
../2configs/retiolum.nix
../2configs/fastpoke-pages.nix
../2configs/new-repos.nix
+ ../2configs/realwallpaper.nix
{
networking.interfaces.enp2s1.ip4 = [
{
- address = "104.167.113.104";
+ address = ip;
prefixLength = 24;
}
];
- networking.defaultGateway = "104.167.113.1";
+ networking.defaultGateway = getDefaultGateway ip;
networking.nameservers = [
"8.8.8.8"
];
@@ -40,4 +47,8 @@
networking.hostName = "cloudkrebs";
+ environment.systemPackages = [
+ pkgs.dic
+ ];
+
}