summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/buildbot-classic/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/simple/buildbot-classic/default.nix')
-rw-r--r--krebs/5pkgs/simple/buildbot-classic/default.nix50
1 files changed, 17 insertions, 33 deletions
diff --git a/krebs/5pkgs/simple/buildbot-classic/default.nix b/krebs/5pkgs/simple/buildbot-classic/default.nix
index 35397210..9eeccee6 100644
--- a/krebs/5pkgs/simple/buildbot-classic/default.nix
+++ b/krebs/5pkgs/simple/buildbot-classic/default.nix
@@ -1,43 +1,27 @@
-{ fetchgit, fetchFromGitHub, python2Packages, git, ... }:
-let
- # https://github.com/NixOS/nixpkgs/issues/14026
- nixpkgs-fix = import (fetchgit {
- url = https://github.com/nixos/nixpkgs;
- rev = "e026b5c243ea39810826e68362718f5d703fb5d0";
- sha256 = "11lqd480bi6xbi7xbh4krrxmbp6a6iafv1d0q3sj461al0x0has8";
- }) {};
+{ pkgs, fetchFromGitHub, python2Packages, git, ... }:
-in nixpkgs-fix.buildPythonApplication {
- name = "buildbot-classic-0.8.13";
+python2Packages.buildPythonApplication rec {
+ name = "buildbot-classic-${version}";
+ version = "0.8.14";
namePrefix = "";
patches = [];
- src = fetchgit {
- url = "https://github.com/krebscode/buildbot-classic";
- rev = "211ec7815";
- sha256 = "0cyn406r31qdqhpsih7w83x47b443svpgfhxqd6w3iryv0y1z95i";
- leaveDotGit = true;
-
+ src = fetchFromGitHub {
+ owner = "krebscode";
+ repo = "buildbot-classic";
+ # rev = "v${version}";
+ rev = "843463911";
+ sha256 = "1ybl52ybjw5p09yik6bck9i1pvnvg94i0d32zqrwy67s77yx1mfd";
};
postUnpack = "sourceRoot=\${sourceRoot}/master";
- buildInputs = [ git ];
- patchPhase =
- # The code insists on /usr/bin/tail, /usr/bin/make, etc.
- '' echo "patching erroneous absolute path references..."
- for i in $(find -name \*.py)
- do
- sed -i "$i" \
- -e "s|/usr/bin/python|$(type -P python)|g ; s|/usr/bin/||g"
- done
-
- sed -i 's/==/>=/' setup.py
- '';
- propagatedBuildInputs = with nixpkgs-fix.pythonPackages; [
- jinja2
- twisted
- dateutil_1_5
- sqlalchemy_migrate_0_7
+ propagatedBuildInputs = [
+ python2Packages.jinja2
+ python2Packages.twisted
+ python2Packages.dateutil_1_5
+ python2Packages.sqlalchemy_migrate
+ python2Packages.pysqlite
+ pkgs.coreutils
];
doCheck = false;
postInstall = ''