summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell/recht.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell/recht.nix')
-rw-r--r--krebs/5pkgs/haskell/recht.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell/recht.nix b/krebs/5pkgs/haskell/recht.nix
new file mode 100644
index 00000000..7d884a9f
--- /dev/null
+++ b/krebs/5pkgs/haskell/recht.nix
@@ -0,0 +1,25 @@
+{ mkDerivation, ansi-terminal, async, base, binary, bytestring
+, data-default, directory, filepath, megaparsec
+, optparse-applicative, pandoc, random, safe, scalpel, stdenv, text
+, time
+, fetchFromGitHub
+}:
+mkDerivation rec {
+ pname = "recht";
+ version = "0.3.0";
+ src = fetchFromGitHub {
+ owner = "kmein";
+ repo = "recht";
+ rev = version;
+ sha256 = "07cyd06wbnzcp33v0nq8cxyggvqrnbni0v2g8cpxar6idn1wlz85";
+
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ ansi-terminal async base binary bytestring data-default directory
+ filepath megaparsec optparse-applicative pandoc random safe scalpel
+ text time
+ ];
+ license = stdenv.lib.licenses.mit;
+}