summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell-overrides
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell-overrides')
-rw-r--r--krebs/5pkgs/haskell-overrides/blessings.nix2
-rw-r--r--krebs/5pkgs/haskell-overrides/hyphenation.nix17
-rw-r--r--krebs/5pkgs/haskell-overrides/scanner.nix2
-rw-r--r--krebs/5pkgs/haskell-overrides/xmonad-stockholm.nix2
4 files changed, 20 insertions, 3 deletions
diff --git a/krebs/5pkgs/haskell-overrides/blessings.nix b/krebs/5pkgs/haskell-overrides/blessings.nix
index ba776b35..5fb57a33 100644
--- a/krebs/5pkgs/haskell-overrides/blessings.nix
+++ b/krebs/5pkgs/haskell-overrides/blessings.nix
@@ -3,7 +3,7 @@ mkDerivation {
pname = "blessings";
version = "1.0.0";
src = fetchgit {
- url = http://cgit.cd.krebsco.de/blessings;
+ url = http://cgit.ni.krebsco.de/blessings;
rev = "25a510dcb38ea9158e9969d56eb66cb1b860ab5f";
sha256 = "0xg329h1y68ndg4w3m1jp38pkg3gqg7r19q70gqqj4mswb6qcrqc";
};
diff --git a/krebs/5pkgs/haskell-overrides/hyphenation.nix b/krebs/5pkgs/haskell-overrides/hyphenation.nix
new file mode 100644
index 00000000..6e5fe945
--- /dev/null
+++ b/krebs/5pkgs/haskell-overrides/hyphenation.nix
@@ -0,0 +1,17 @@
+# Same as upstream but with doCheck = false because doctest has wrong version.
+{ mkDerivation, base, bytestring, containers, directory
+, filepath, unordered-containers, zlib, stdenv
+}:
+mkDerivation {
+ pname = "hyphenation";
+ version = "0.6";
+ sha256 = "2f673666c18f63581422f7c6389b78b0ff754406671296a3d680d417942512f7";
+ libraryHaskellDepends = [
+ base bytestring containers unordered-containers zlib
+ ];
+ homepage = "http://github.com/ekmett/hyphenation";
+ description = "Configurable Knuth-Liang hyphenation";
+ license = stdenv.lib.licenses.bsd3;
+ hydraPlatforms = stdenv.lib.platforms.none;
+ doCheck = false;
+}
diff --git a/krebs/5pkgs/haskell-overrides/scanner.nix b/krebs/5pkgs/haskell-overrides/scanner.nix
index 5146fa41..071fd757 100644
--- a/krebs/5pkgs/haskell-overrides/scanner.nix
+++ b/krebs/5pkgs/haskell-overrides/scanner.nix
@@ -3,7 +3,7 @@ mkDerivation {
pname = "scanner";
version = "1.0.0";
src = fetchgit {
- url = http://cgit.cd.krebsco.de/scanner;
+ url = http://cgit.ni.krebsco.de/scanner;
rev = "7f091a3bc152ad3974a1873b460fa1759bf8dcad";
sha256 = "1lgl158axczsm4fx53fyq1d4116v91jsx4dbz66ka4k1ljqrmhgn";
};
diff --git a/krebs/5pkgs/haskell-overrides/xmonad-stockholm.nix b/krebs/5pkgs/haskell-overrides/xmonad-stockholm.nix
index 12eab943..bf19e7d6 100644
--- a/krebs/5pkgs/haskell-overrides/xmonad-stockholm.nix
+++ b/krebs/5pkgs/haskell-overrides/xmonad-stockholm.nix
@@ -5,7 +5,7 @@ mkDerivation {
pname = "xmonad-stockholm";
version = "1.1.0";
src = fetchgit {
- url = http://cgit.cd.krebsco.de/xmonad-stockholm;
+ url = http://cgit.ni.krebsco.de/xmonad-stockholm;
rev = "179d29fd4c765dee698058ef63295331ac603639";
sha256 = "0c6mj68xsxxr4j8adkzhjszi7bg6cpisrsmqn587a16sblpbrnkj";
};