summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index 7792b31d..fcb6ff3d 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -1,4 +1,4 @@
-{ lib, ... }:
+{ config, lib, ... }:
with builtins;
with lib;
@@ -22,11 +22,7 @@ types // rec {
owner = mkOption {
type = user;
- # TODO proper user
- default = {
- name = "krebs";
- mail = "spam@krebsco.de";
- };
+ default = config.krebs.users.krebs;
};
extraZones = mkOption {
@@ -183,7 +179,8 @@ types // rec {
default = config._module.args.name;
};
pubkey = mkOption {
- type = str;
+ type = nullOr str;
+ default = null;
};
uid = mkOption {
type = int;