summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/4lib/shell.nix')
-rw-r--r--krebs/4lib/shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/krebs/4lib/shell.nix b/krebs/4lib/shell.nix
new file mode 100644
index 00000000..48b220f8
--- /dev/null
+++ b/krebs/4lib/shell.nix
@@ -0,0 +1,15 @@
+{ lib, ... }:
+
+with builtins;
+with lib;
+
+rec {
+ escape =
+ let
+ isSafeChar = c: match "[-./0-9_a-zA-Z]" c != null;
+ in
+ stringAsChars (c:
+ if isSafeChar c then c
+ else if c == "\n" then "'\n'"
+ else "\\${c}");
+}