summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/tinc_graphs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/tinc_graphs.nix')
-rw-r--r--krebs/3modules/tinc_graphs.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/krebs/3modules/tinc_graphs.nix b/krebs/3modules/tinc_graphs.nix
index e415d20a..ba81dd41 100644
--- a/krebs/3modules/tinc_graphs.nix
+++ b/krebs/3modules/tinc_graphs.nix
@@ -89,9 +89,10 @@ let
};
restartIfChanged = true;
-
serviceConfig = {
Type = "simple";
+ TimeoutSec = 300; # we will wait 5 minutes, kill otherwise
+ restart = "always";
ExecStartPre = pkgs.writeScript "tinc_graphs-init" ''
#!/bin/sh
@@ -103,7 +104,6 @@ let
cp -fr "$(${pkgs.tinc_graphs}/bin/tincstats-static-dir)/external/." "${external_dir}"
fi
'';
-
ExecStart = "${pkgs.tinc_graphs}/bin/all-the-graphs";
ExecStartPost = pkgs.writeScript "tinc_graphs-post" ''