summaryrefslogtreecommitdiffstats
path: root/krebs/3modules/Reaktor.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/3modules/Reaktor.nix')
-rw-r--r--krebs/3modules/Reaktor.nix15
1 files changed, 11 insertions, 4 deletions
diff --git a/krebs/3modules/Reaktor.nix b/krebs/3modules/Reaktor.nix
index 407f1bce..fce24fa6 100644
--- a/krebs/3modules/Reaktor.nix
+++ b/krebs/3modules/Reaktor.nix
@@ -40,7 +40,7 @@ let
nickname = mkOption {
default = config.krebs.build.host.name + "|r";
- type = types.str;
+ type = types.string;
description = ''
The nick name of the irc bot.
Defaults to {hostname}|r
@@ -58,7 +58,7 @@ let
};
extraConfig = mkOption {
default = "";
- type = types.str;
+ type = types.string;
description = ''
configuration appended to the default or overridden configuration
'';
@@ -70,6 +70,12 @@ let
the Reaktor pkg to use.
'';
};
+ debug = mkOption {
+ default = false;
+ description = ''
+ Reaktor debug output
+ '';
+ };
};
imp = {
@@ -101,6 +107,7 @@ let
environment = {
GIT_SSL_CAINFO = "${pkgs.cacert}/etc/ssl/certs/ca-bundle.crt";
REAKTOR_NICKNAME = cfg.nickname;
+ REAKTOR_DEBUG = (if cfg.debug then "True" else "False");
};
serviceConfig= {
ExecStartPre = pkgs.writeScript "Reaktor-init" ''
@@ -115,8 +122,8 @@ let
PrivateTmp = "true";
User = "Reaktor";
Restart = "on-abort";
- #StartLimitInterval = "5m";
- #StartLimitBurst = "1";
+ StartLimitInterval = "1m";
+ StartLimitBurst = "1";
};
};
};