summaryrefslogtreecommitdiffstats
path: root/krebs/2configs/buildbot/worker.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/2configs/buildbot/worker.nix')
-rw-r--r--krebs/2configs/buildbot/worker.nix4
1 files changed, 3 insertions, 1 deletions
diff --git a/krebs/2configs/buildbot/worker.nix b/krebs/2configs/buildbot/worker.nix
index e96c6df14..5526a83d3 100644
--- a/krebs/2configs/buildbot/worker.nix
+++ b/krebs/2configs/buildbot/worker.nix
@@ -1,4 +1,4 @@
-{ buildbot-nix, ... }:
+{ config, buildbot-nix, ... }:
{
imports = [
buildbot-nix.nixosModules.buildbot-worker
@@ -6,6 +6,8 @@
services.buildbot-nix.worker = {
enable = true;
+ name = config.krebs.build.host.name;
workerPasswordFile = "/var/src/secrets/nix-worker-file";
+ masterUrl = "tcp:host=gum:port=9989";
};
}