summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/brauerei/config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'jeschli/1systems/brauerei/config.nix')
-rw-r--r--jeschli/1systems/brauerei/config.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/jeschli/1systems/brauerei/config.nix b/jeschli/1systems/brauerei/config.nix
index 2dec4579..eb2bb11d 100644
--- a/jeschli/1systems/brauerei/config.nix
+++ b/jeschli/1systems/brauerei/config.nix
@@ -35,6 +35,13 @@
time.timeZone = "Europe/Amsterdam";
nixpkgs.config.allowUnfree = true;
# List packages installed in system profile. To search by name, run: # $ nix-env -qaP | grep wget
+ environment.shellAliases = {
+ n = "nix-shell";
+ stocki = pkgs.writeDash "deploy" ''
+ cd ~/stockholm
+ exec nix-shell -I stockholm="$PWD" --run 'deploy --system="brauerei"'
+ '';
+ };
environment.systemPackages = with pkgs; [
# system helper
ag
@@ -72,6 +79,8 @@
jetbrains.goland
# document viewer
zathura
+ # xorg
+ xorg.xbacklight
];
# Some programs need SUID wrappers, can be configured further or are