summaryrefslogtreecommitdiffstats
path: root/Zpkgs/krebs/hashPassword.nix
diff options
context:
space:
mode:
Diffstat (limited to 'Zpkgs/krebs/hashPassword.nix')
-rw-r--r--Zpkgs/krebs/hashPassword.nix16
1 files changed, 0 insertions, 16 deletions
diff --git a/Zpkgs/krebs/hashPassword.nix b/Zpkgs/krebs/hashPassword.nix
deleted file mode 100644
index a10340cc..00000000
--- a/Zpkgs/krebs/hashPassword.nix
+++ /dev/null
@@ -1,16 +0,0 @@
-{ lib, pkgs, ... }:
-
-pkgs.writeScriptBin "hashPassword" ''
- #! /bin/sh
- # usage: hashPassword
- set -euf
-
- export PATH=${lib.makeSearchPath "bin" (with pkgs; [
- coreutils
- mkpasswd
- openssl
- ])}
-
- salt=$(openssl rand -base64 16 | tr -d '+=' | head -c 16)
- exec mkpasswd -m sha-512 -S "$salt"
-''