summaryrefslogtreecommitdiffstats
path: root/4lib/tv/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '4lib/tv/default.nix')
-rw-r--r--4lib/tv/default.nix52
1 files changed, 0 insertions, 52 deletions
diff --git a/4lib/tv/default.nix b/4lib/tv/default.nix
deleted file mode 100644
index 16888c21..00000000
--- a/4lib/tv/default.nix
+++ /dev/null
@@ -1,52 +0,0 @@
-{ lib, pkgs, ... }:
-
-let
- krebs = import ../../4lib/krebs { inherit lib; };
-in
-
-with krebs;
-
-krebs // rec {
-
- git = import ./git.nix {
- lib = lib // {
- inherit addNames;
- };
- inherit pkgs;
- };
-
- # "7.4.335" -> "74"
- majmin = with lib; x : concatStrings (take 2 (splitString "." x));
-
- concat = xs :
- if xs == []
- then ""
- else head xs + concat (tail xs)
- ;
-
- flip = f : x : y : f y x;
-
- # isSuffixOf :: String -> String -> Bool
- isSuffixOf =
- s : xs :
- let
- sn = stringLength s;
- xsn = stringLength xs;
- in
- xsn >= sn && substring (xsn - sn) sn xs == s ;
-
- # setMap :: (String -> a -> b) -> Set String a -> [b]
- #setMap = f: xs: map (k : f k (getAttr k xs)) (attrNames xs);
-
- # setToList :: Set k a -> [a]
- #setToList = setMap (_: v: v);
-
- shell-escape =
- let
- isSafeChar = c: match "[-./0-9_a-zA-Z]" c != null;
- in
- stringAsChars (c:
- if isSafeChar c then c
- else if c == "\n" then "'\n'"
- else "\\${c}");
-}