summaryrefslogtreecommitdiffstats
path: root/4lib/krebs/types.nix
diff options
context:
space:
mode:
Diffstat (limited to '4lib/krebs/types.nix')
-rw-r--r--4lib/krebs/types.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/4lib/krebs/types.nix b/4lib/krebs/types.nix
index 38ed8a91..9d02c779 100644
--- a/4lib/krebs/types.nix
+++ b/4lib/krebs/types.nix
@@ -20,6 +20,15 @@ types // rec {
type = attrsOf net;
apply = x: assert hasAttr "retiolum" x; x;
};
+ secure = mkOption {
+ type = bool;
+ default = false;
+ description = ''
+ If true, then the host is capable of keeping secret information.
+
+ TODO define minimum requirements for secure hosts
+ '';
+ };
};
};