summaryrefslogtreecommitdiffstats
path: root/3modules/tv/urlwatch.nix
diff options
context:
space:
mode:
Diffstat (limited to '3modules/tv/urlwatch.nix')
-rw-r--r--3modules/tv/urlwatch.nix12
1 files changed, 2 insertions, 10 deletions
diff --git a/3modules/tv/urlwatch.nix b/3modules/tv/urlwatch.nix
index d6e796ca..aed24785 100644
--- a/3modules/tv/urlwatch.nix
+++ b/3modules/tv/urlwatch.nix
@@ -7,11 +7,12 @@
with builtins;
with lib;
-
let
cfg = config.tv.urlwatch;
api = {
+ enable = mkEnableOption "tv.urlwatch";
+
dataDir = mkOption {
type = types.str;
default = "/var/lib/urlwatch";
@@ -19,15 +20,6 @@ let
Directory where the urlwatch service should store its state.
'';
};
- enable = mkOption {
- type = types.bool;
- default = false;
- description = ''
- Whether to enable the urlwatch service.
- If enabled, then create a timer that calls urlwatch and sends mails
- whenever something has changed or an error occurs.
- '';
- };
from = mkOption {
type = types.str;
default = "${cfg.user}@${config.networking.hostName}.retiolum";