summaryrefslogtreecommitdiffstats
path: root/1systems/tv/wu.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/tv/wu.nix')
-rw-r--r--1systems/tv/wu.nix14
1 files changed, 13 insertions, 1 deletions
diff --git a/1systems/tv/wu.nix b/1systems/tv/wu.nix
index f542581b..192b65b9 100644
--- a/1systems/tv/wu.nix
+++ b/1systems/tv/wu.nix
@@ -35,6 +35,19 @@ in
exec ${pkgs.firefoxWrapper}/bin/firefox $(printf " %q" "$@")
EOF
'')
+ (pkgs.writeScriptBin "im" ''
+ #! ${pkgs.bash}/bin/bash
+ export PATH=${makeSearchPath "bin" (with pkgs; [
+ tmux
+ gnugrep
+ weechat
+ ])}
+ if tmux list-sessions -F\#S | grep -q '^im''$'; then
+ exec tmux attach -t im
+ else
+ exec tmux new -s im weechat
+ fi
+ '')
# root
cryptsetup
@@ -62,7 +75,6 @@ in
sxiv
texLive
tmux
- weechat
zathura
Zpkgs.dic