summaryrefslogtreecommitdiffstats
path: root/1systems/tv/rmdir.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/tv/rmdir.nix')
-rw-r--r--1systems/tv/rmdir.nix68
1 files changed, 0 insertions, 68 deletions
diff --git a/1systems/tv/rmdir.nix b/1systems/tv/rmdir.nix
deleted file mode 100644
index 9233014b..00000000
--- a/1systems/tv/rmdir.nix
+++ /dev/null
@@ -1,68 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-{
- krebs.build.host = config.krebs.hosts.rmdir;
-
- imports = [
- ../../2configs/tv/CAC-Developer-1.nix
- ../../2configs/tv/CAC-CentOS-7-64bit.nix
- ../../2configs/tv/base.nix
- ../../2configs/tv/consul-server.nix
- ../../2configs/tv/exim-smarthost.nix
- ../../2configs/tv/git.nix
- {
- tv.iptables = {
- enable = true;
- input-internet-accept-new-tcp = [
- "ssh"
- "tinc"
- "smtp"
- ];
- input-retiolum-accept-new-tcp = [
- "http"
- ];
- };
- }
- {
- krebs.retiolum = {
- enable = true;
- connectTo = [
- "cd"
- "mkdir"
- "fastpoke"
- "pigstarter"
- "ire"
- ];
- };
- }
- ];
-
- networking.interfaces.enp2s1.ip4 = [
- {
- address = "167.88.44.94";
- prefixLength = 24;
- }
- ];
- networking.defaultGateway = "167.88.44.1";
- networking.nameservers = [
- "8.8.8.8"
- ];
-
- environment.systemPackages = with pkgs; [
- git # required for ./deploy, clone_or_update
- htop
- iftop
- iotop
- iptables
- nethogs
- rxvt_unicode.terminfo
- tcpdump
- ];
-
- services.journald.extraConfig = ''
- SystemMaxUse=1G
- RuntimeMaxUse=128M
- '';
-}