summaryrefslogtreecommitdiffstats
path: root/1systems/tv/rmdir.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/tv/rmdir.nix')
-rw-r--r--1systems/tv/rmdir.nix14
1 files changed, 4 insertions, 10 deletions
diff --git a/1systems/tv/rmdir.nix b/1systems/tv/rmdir.nix
index b77a1c39..9233014b 100644
--- a/1systems/tv/rmdir.nix
+++ b/1systems/tv/rmdir.nix
@@ -3,19 +3,16 @@
with lib;
{
+ krebs.build.host = config.krebs.hosts.rmdir;
+
imports = [
../../2configs/tv/CAC-Developer-1.nix
../../2configs/tv/CAC-CentOS-7-64bit.nix
../../2configs/tv/base.nix
../../2configs/tv/consul-server.nix
../../2configs/tv/exim-smarthost.nix
- ../../2configs/tv/git-public.nix
- {
- imports = [ ../../2configs/tv/identity.nix ];
- tv.identity.self = config.tv.identity.hosts.rmdir;
- }
+ ../../2configs/tv/git.nix
{
- imports = [ ../../3modules/tv/iptables.nix ];
tv.iptables = {
enable = true;
input-internet-accept-new-tcp = [
@@ -29,10 +26,8 @@ with lib;
};
}
{
- imports = [ ../../3modules/tv/retiolum.nix ];
- tv.retiolum = {
+ krebs.retiolum = {
enable = true;
- hosts = ../../Zhosts;
connectTo = [
"cd"
"mkdir"
@@ -44,7 +39,6 @@ with lib;
}
];
- networking.hostName = "rmdir";
networking.interfaces.enp2s1.ip4 = [
{
address = "167.88.44.94";