summaryrefslogtreecommitdiffstats
path: root/1systems/lass/uriel.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/lass/uriel.nix')
-rw-r--r--1systems/lass/uriel.nix53
1 files changed, 12 insertions, 41 deletions
diff --git a/1systems/lass/uriel.nix b/1systems/lass/uriel.nix
index 25745d05..4fe8cf21 100644
--- a/1systems/lass/uriel.nix
+++ b/1systems/lass/uriel.nix
@@ -1,38 +1,32 @@
{ config, pkgs, ... }:
+with builtins;
{
imports = [
../../2configs/lass/desktop-base.nix
../../2configs/lass/browsers.nix
../../2configs/lass/games.nix
../../2configs/lass/pass.nix
- ../../2configs/lass/vim.nix
../../2configs/lass/urxvt.nix
../../2configs/lass/bird.nix
- ../../2configs/lass/git-repos.nix
+ ../../2configs/lass/new-repos.nix
../../2configs/lass/chromium-patched.nix
- ../../2configs/tv/exim-retiolum.nix
+ ../../2configs/lass/retiolum.nix
{
- imports = [ ../../3modules/tv/retiolum.nix ];
- tv.retiolum = {
- enable = true;
- hosts = ../../Zhosts;
- connectTo = [
- "fastpoke"
- "gum"
- "pigstarter"
- ];
- };
- }
- {
- imports = [ ../../3modules/tv/identity.nix ];
- tv.identity = {
- enable = true;
+ users.extraUsers = {
+ root = {
+ openssh.authorizedKeys.keys = map readFile [
+ ../../Zpubkeys/uriel.ssh.pub
+ ];
+ };
};
}
];
+ krebs.enable = true;
+ krebs.build.host = config.krebs.hosts.uriel;
networking.hostName = "uriel";
+
networking.wireless.enable = true;
nix.maxJobs = 2;
@@ -87,29 +81,6 @@
'';
};
- users.extraUsers = {
- root = {
- openssh.authorizedKeys.keys = [
- config.sshKeys.lass.pub
- ];
- };
- mainUser = {
- uid = 1337;
- name = "lass";
- #isNormalUser = true;
- group = "users";
- createHome = true;
- home = "/home/lass";
- useDefaultShell = true;
- isSystemUser = false;
- description = "lassulus";
- extraGroups = [ "wheel" "audio" ];
- openssh.authorizedKeys.keys = [
- config.sshKeys.lass.pub
- ];
- };
- };
-
environment.systemPackages = with pkgs; [
];