summaryrefslogtreecommitdiffstats
path: root/1systems/lass/cloudkrebs.nix
diff options
context:
space:
mode:
Diffstat (limited to '1systems/lass/cloudkrebs.nix')
-rw-r--r--1systems/lass/cloudkrebs.nix43
1 files changed, 43 insertions, 0 deletions
diff --git a/1systems/lass/cloudkrebs.nix b/1systems/lass/cloudkrebs.nix
new file mode 100644
index 00000000..dc27affe
--- /dev/null
+++ b/1systems/lass/cloudkrebs.nix
@@ -0,0 +1,43 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ../../2configs/tv/CAC-Developer-2.nix
+ ../../2configs/tv/CAC-CentOS-7-64bit.nix
+ ../../2configs/lass/base.nix
+ {
+ networking.interfaces.enp2s1.ip4 = [
+ {
+ address = "104.167.113.104";
+ prefixLength = 24;
+ }
+ ];
+ networking.defaultGateway = "104.167.113.1";
+ networking.nameservers = [
+ "8.8.8.8"
+ ];
+
+ }
+ {
+ imports = [ ../../3modules/tv/retiolum.nix ];
+ tv.retiolum = {
+ enable = true;
+ hosts = ../../Zhosts;
+ connectTo = [
+ "fastpoke"
+ "gum"
+ "pigstarter"
+ ];
+ };
+ }
+ {
+ imports = [ ../../3modules/tv/identity.nix ];
+ tv.identity = {
+ enable = true;
+ };
+ }
+ ];
+
+ networking.hostName = "cloudkrebs";
+
+}