summaryrefslogtreecommitdiffstats
path: root/tv/systems/rmdir.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-28 20:40:25 +0200
committertv <tv@shackspace.de>2015-07-28 20:40:25 +0200
commit8170b281964688b542fb151054c5d86d819008b3 (patch)
treea37b713c7662dbaef73508bca889c83c7dc5a620 /tv/systems/rmdir.nix
parenta7ff77b6c147be71d60bda7e73c65286ecfb7c83 (diff)
tv: reintroduce directory numbers
Diffstat (limited to 'tv/systems/rmdir.nix')
-rw-r--r--tv/systems/rmdir.nix84
1 files changed, 0 insertions, 84 deletions
diff --git a/tv/systems/rmdir.nix b/tv/systems/rmdir.nix
deleted file mode 100644
index fa91516d..00000000
--- a/tv/systems/rmdir.nix
+++ /dev/null
@@ -1,84 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-{
- krebs.build.host = config.krebs.hosts.rmdir;
- krebs.build.user = config.krebs.users.tv;
-
- krebs.build.target = "root@rmdir.internet";
-
- krebs.build.deps = {
- nixpkgs = {
- url = https://github.com/NixOS/nixpkgs;
- rev = "4c01e6d91993b6de128795f4fbdd25f6227fb870";
- };
- secrets = {
- url = "/home/tv/secrets/${config.krebs.build.host.name}";
- };
- stockholm = {
- url = toString ../..;
- };
- };
-
- imports = [
- ../configs/CAC-Developer-1.nix
- ../configs/CAC-CentOS-7-64bit.nix
- ../configs/base.nix
- ../configs/consul-server.nix
- ../configs/exim-smarthost.nix
- ../configs/git.nix
- {
- tv.iptables = {
- enable = true;
- input-internet-accept-new-tcp = [
- "ssh"
- "tinc"
- "smtp"
- ];
- input-retiolum-accept-new-tcp = [
- "http"
- ];
- };
- }
- {
- krebs.retiolum = {
- enable = true;
- connectTo = [
- "cd"
- "mkdir"
- "fastpoke"
- "pigstarter"
- "ire"
- ];
- };
- }
- ];
-
- networking.interfaces.enp2s1.ip4 = [
- {
- address = "167.88.44.94";
- prefixLength = 24;
- }
- ];
- networking.defaultGateway = "167.88.44.1";
- networking.nameservers = [
- "8.8.8.8"
- ];
-
- environment.systemPackages = with pkgs; [
- git # required for ./deploy, clone_or_update
- htop
- iftop
- iotop
- iptables
- nethogs
- rxvt_unicode.terminfo
- tcpdump
- ];
-
- services.journald.extraConfig = ''
- SystemMaxUse=1G
- RuntimeMaxUse=128M
- '';
-}