summaryrefslogtreecommitdiffstats
path: root/tv/configs/consul-server.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-27 02:02:34 +0200
committertv <tv@shackspace.de>2015-07-27 02:02:34 +0200
commitafb6afff1d0f81d8a0dcfd94fa8e46a849bb094f (patch)
treeebdbaf99b0e2fcde8be0bd43455955e5cd17b3be /tv/configs/consul-server.nix
parent45b173c11ecc7d6e8a177d7121bd06d923691b4b (diff)
* tv -> tv *
Diffstat (limited to 'tv/configs/consul-server.nix')
-rw-r--r--tv/configs/consul-server.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tv/configs/consul-server.nix b/tv/configs/consul-server.nix
new file mode 100644
index 00000000..d10f9ea7
--- /dev/null
+++ b/tv/configs/consul-server.nix
@@ -0,0 +1,21 @@
+{ config, ... }:
+
+{
+ tv.consul = rec {
+ enable = true;
+
+ self = config.krebs.build.host;
+ inherit (self) dc;
+
+ server = true;
+
+ hosts = with config.krebs.hosts; [
+ # TODO get this list automatically from each host where tv.consul.enable is true
+ cd
+ mkdir
+ nomic
+ rmdir
+ #wu
+ ];
+ };
+}