summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/vim/default.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2022-12-12 19:44:00 +0100
committermakefu <github@syntax-fehler.de>2022-12-12 19:44:00 +0100
commit6eb5e44b7e5bdc8b1b3b5ffe40c146841f7afd10 (patch)
treef706bf7c3c7a289f680ac329caa2b578e5145a56 /tv/5pkgs/vim/default.nix
parent96e934dc8a353cff91ef824f6a125ed49996d058 (diff)
parent3884243448869bdf09f6434b385e532c7c26ae88 (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'tv/5pkgs/vim/default.nix')
-rw-r--r--tv/5pkgs/vim/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/tv/5pkgs/vim/default.nix b/tv/5pkgs/vim/default.nix
index 5582be3fd..c143592ad 100644
--- a/tv/5pkgs/vim/default.nix
+++ b/tv/5pkgs/vim/default.nix
@@ -1,7 +1,11 @@
-with import <stockholm/lib>;
+with import ./lib;
self: super: {
tv = super.tv // {
+ vim = {
+ makePlugin = outPath: outPath // { inherit outPath; };
+ makeRuntimePath = concatMapStringsSep "," (getAttr "outPath");
+ };
vimPlugins = mapNixDir (path: self.callPackage path {}) ./.;
};
}