summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/haskell/mailaids.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2020-12-30 13:00:28 +0100
committerlassulus <lassulus@lassul.us>2020-12-30 13:00:28 +0100
commit50a3903825c8932b87b3fb6be77245688be76534 (patch)
tree7cafca39fc1d805259afc5f52dbad51f21e81932 /tv/5pkgs/haskell/mailaids.nix
parent053044834c1af30a90ced1338ae4342a445a2946 (diff)
parent9c2529b2910bdb3b73bcd69ed958d82e01bf7943 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/5pkgs/haskell/mailaids.nix')
-rw-r--r--tv/5pkgs/haskell/mailaids.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/tv/5pkgs/haskell/mailaids.nix b/tv/5pkgs/haskell/mailaids.nix
new file mode 100644
index 00000000..b705c7c6
--- /dev/null
+++ b/tv/5pkgs/haskell/mailaids.nix
@@ -0,0 +1,21 @@
+{ mkDerivation, aeson, aeson-pretty, base, bytestring
+, case-insensitive, fetchgit, lens, optparse-applicative
+, purebred-email, stdenv, text, vector, word8
+}:
+mkDerivation {
+ pname = "mailaids";
+ version = "1.0.0";
+ src = fetchgit {
+ url = "https://cgit.krebsco.de/mailaids";
+ sha256 = "15h0k82czm89gkwhp1rwdy77jz8dmb626qdz7c2narvz9j7169v5";
+ rev = "8f11927ea74d6adb332c884502ebd9c486837523";
+ fetchSubmodules = true;
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ aeson aeson-pretty base bytestring case-insensitive lens
+ optparse-applicative purebred-email text vector word8
+ ];
+ license = stdenv.lib.licenses.mit;
+}