summaryrefslogtreecommitdiffstats
path: root/tv/3modules/hw.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-02-15 19:09:42 +0100
committermakefu <github@syntax-fehler.de>2021-02-15 19:09:42 +0100
commitda0ab68232757e19e1ec26e88331b88afea9e8fc (patch)
tree00ebd863f07b8e569a856107f08be8de9ff3a8bc /tv/3modules/hw.nix
parentdc7dca887a082666b3e4c7592239131181bc42c1 (diff)
parent9365aff352d99b7506bafbef6682de7bfb00df27 (diff)
Merge remote-tracking branch 'tv/master'
Diffstat (limited to 'tv/3modules/hw.nix')
-rw-r--r--tv/3modules/hw.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/tv/3modules/hw.nix b/tv/3modules/hw.nix
new file mode 100644
index 00000000..6eb722d2
--- /dev/null
+++ b/tv/3modules/hw.nix
@@ -0,0 +1,16 @@
+let
+ lib = import <stockholm/lib>;
+ local.types.screen = lib.types.submodule {
+ options.width = lib.mkOption {
+ type = lib.types.uint;
+ };
+ options.height = lib.mkOption {
+ type = lib.types.uint;
+ };
+ };
+in {
+ options.tv.hw.screens = lib.mkOption {
+ type = lib.types.attrsOf local.types.screen;
+ default = {};
+ };
+}