summaryrefslogtreecommitdiffstats
path: root/tv/3modules/hosts.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2016-08-03 09:28:59 +0200
committermakefu <github@syntax-fehler.de>2016-08-03 09:28:59 +0200
commitcba2979f860e3b55f82c58883bac84ceacd005bb (patch)
treeee421f8093206d76b61781e7777baa66816c412b /tv/3modules/hosts.nix
parentb68633c0272514dd4f2d235796f87021664730c2 (diff)
parent46d73a70ce2df4af2d66228874470cb4c8657f14 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'tv/3modules/hosts.nix')
-rw-r--r--tv/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tv/3modules/hosts.nix b/tv/3modules/hosts.nix
new file mode 100644
index 00000000..7bf3267c
--- /dev/null
+++ b/tv/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with config.krebs.lib;
+
+{
+ options.tv.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "tv")
+ config.krebs.hosts;
+ };
+}