summaryrefslogtreecommitdiffstats
path: root/tv/2configs/xserver/xserver.conf.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-10-25 00:23:59 +0200
committermakefu <github@syntax-fehler.de>2015-10-25 00:23:59 +0200
commitc62885a0bcf4a1a09400aa69d83723857ab558d8 (patch)
tree2df3980c179c8da1ffb584fe9dd73f66da09d347 /tv/2configs/xserver/xserver.conf.nix
parenta1d05482e5527d32baef9d9343b900dee8d46694 (diff)
parenta4d7f920bf49de6237191558d02b0f58ed307fd4 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'tv/2configs/xserver/xserver.conf.nix')
-rw-r--r--tv/2configs/xserver/xserver.conf.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/tv/2configs/xserver/xserver.conf.nix b/tv/2configs/xserver/xserver.conf.nix
new file mode 100644
index 00000000..e8a997a9
--- /dev/null
+++ b/tv/2configs/xserver/xserver.conf.nix
@@ -0,0 +1,40 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+ cfg = config.services.xserver;
+in
+
+pkgs.stdenv.mkDerivation {
+ name = "xserver.conf";
+
+ xfs = optionalString (cfg.useXFS != false)
+ ''FontPath "${toString cfg.useXFS}"'';
+
+ inherit (cfg) config;
+
+ buildCommand =
+ ''
+ echo 'Section "Files"' >> $out
+ echo $xfs >> $out
+
+ for i in ${toString config.fonts.fonts}; do
+ if test "''${i:0:''${#NIX_STORE}}" == "$NIX_STORE"; then
+ for j in $(find $i -name fonts.dir); do
+ echo " FontPath \"$(dirname $j)\"" >> $out
+ done
+ fi
+ done
+
+ for i in $(find ${toString cfg.modules} -type d); do
+ if test $(echo $i/*.so* | wc -w) -ne 0; then
+ echo " ModulePath \"$i\"" >> $out
+ fi
+ done
+
+ echo 'EndSection' >> $out
+
+ echo "$config" >> $out
+ '';
+}