summaryrefslogtreecommitdiffstats
path: root/tv/2configs/vim.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-05-25 11:14:32 +0200
committerlassulus <lass@aidsballs.de>2016-05-25 11:14:32 +0200
commita240a60b52684466a207a43e944e0f040ec75361 (patch)
tree13e872ba019942f6509e2ed17649d44603c3e841 /tv/2configs/vim.nix
parent0f2fc7c4a6a9bb41b965c905949aefebbb6c3f49 (diff)
parent36c5834c288b56b6955e35d95708ae7f65f199f9 (diff)
Merge remote-tracking branch 'cd/master' into HEAD
Diffstat (limited to 'tv/2configs/vim.nix')
-rw-r--r--tv/2configs/vim.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/tv/2configs/vim.nix b/tv/2configs/vim.nix
index 6e205948..10e5aab5 100644
--- a/tv/2configs/vim.nix
+++ b/tv/2configs/vim.nix
@@ -111,6 +111,13 @@ let
syn match String /"\([^\\"]\|\\.\)*"/
syn match Comment /\(^\|\s\)#.*/
+ " Haskell comments
+ syn region Comment start=/\(^\|\s\){-#/ end=/#-}/
+ syn match Comment /\(^\|\s\)--.*/
+
+ " Vim comments
+ syn match Comment /\(^\|\s\)"[^"]*$/
+
let b:current_syntax = "nix"
''}