summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/x220.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-10-31 09:38:45 +0100
committerjeschli <jeschli@gmail.com>2018-10-31 09:38:45 +0100
commit98449827e26c2c835019eb20ed4d4f3747f4c190 (patch)
treee71ef60c6dbae949f5cba35a483d46855d52458f /tv/2configs/hw/x220.nix
parenta6670e5090dd71aacd7c7605b12d8d3410d25daa (diff)
parentf130c335de0f902b29bad5da60051d6fa2bdef4e (diff)
Merge remote-tracking branch 'origin/master'
Diffstat (limited to 'tv/2configs/hw/x220.nix')
-rw-r--r--tv/2configs/hw/x220.nix22
1 files changed, 20 insertions, 2 deletions
diff --git a/tv/2configs/hw/x220.nix b/tv/2configs/hw/x220.nix
index e0a04e21..38a89cfc 100644
--- a/tv/2configs/hw/x220.nix
+++ b/tv/2configs/hw/x220.nix
@@ -1,10 +1,28 @@
-{ pkgs, ... }:
-
+{ config, pkgs, ... }:
{
imports = [
../smartd.nix
+ {
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.acpi_call
+ ];
+
+ boot.kernelModules = [
+ "acpi_call"
+ ];
+
+ environment.systemPackages = [
+ pkgs.tpacpi-bat
+ ];
+ }
];
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.tp_smapi
+ ];
+
+ boot.kernelModules = [ "tp_smapi" ];
+
boot.loader.systemd-boot.enable = true;
boot.loader.efi.canTouchEfiVariables = true;