summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/winmax2.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2023-01-19 14:11:01 +0100
committerlassulus <lassulus@lassul.us>2023-01-19 14:11:01 +0100
commitb51998cfae7b6fe892f9f0f9a2c0ffcfeeded0ba (patch)
treeca76ec46d32a99edacfd2d0be19a7f1ef410fe76 /tv/2configs/hw/winmax2.nix
parent347bb9ae00f8f1b6942f94d4c983593052a5c227 (diff)
parent57abca263fe86259807e5597d1c8f11c3c3acd44 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/2configs/hw/winmax2.nix')
-rw-r--r--tv/2configs/hw/winmax2.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/tv/2configs/hw/winmax2.nix b/tv/2configs/hw/winmax2.nix
new file mode 100644
index 00000000..0a207f23
--- /dev/null
+++ b/tv/2configs/hw/winmax2.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }: {
+ boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "thunderbolt" "usbhid" ];
+ boot.initrd.kernelModules = [ "amdgpu" ];
+ boot.kernelModules = [ "kvm-amd" ];
+
+ hardware.cpu.amd.updateMicrocode = true;
+ hardware.enableRedistributableFirmware = true;
+
+ hardware.opengl.enable = true;
+ hardware.opengl.extraPackages = [
+ pkgs.amdvlk
+ pkgs.rocm-opencl-icd
+ pkgs.rocm-opencl-runtime
+ ];
+
+ hardware.video.hidpi.enable = true;
+
+ networking.wireless.enable = true;
+ networking.wireless.interfaces = [
+ "wlp1s0"
+ ];
+ networking.interfaces.wlp1s0.useDHCP = true;
+
+ nixpkgs.hostPlatform = "x86_64-linux";
+
+ services.illum.enable = true;
+
+ tv.lidControl.enable = true;
+
+ tv.hw.screens.primary.width = 2560;
+ tv.hw.screens.primary.height = 1600;
+}