summaryrefslogtreecommitdiffstats
path: root/tv/2configs/hw/AO753.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-10-31 00:13:32 +0100
committerlassulus <lass@aidsballs.de>2015-10-31 00:13:32 +0100
commit5b4a34062462311973bb1798fe3e4538e6eb5706 (patch)
tree31ac952feeb3f534b57fc48c6ae2f71795be2f43 /tv/2configs/hw/AO753.nix
parent611f8ef25b4c3984f2f7de7362c4869d1f2f124f (diff)
parentbcaf3771d9503f1b0d01a2c15ca0712ee454342f (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'tv/2configs/hw/AO753.nix')
-rw-r--r--tv/2configs/hw/AO753.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/tv/2configs/hw/AO753.nix b/tv/2configs/hw/AO753.nix
new file mode 100644
index 00000000..acd9ee32
--- /dev/null
+++ b/tv/2configs/hw/AO753.nix
@@ -0,0 +1,46 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ../smartd.nix
+ ];
+
+ boot.loader.grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ahci"
+ ];
+
+ boot.kernelModules = [
+ "kvm-intel"
+ "wl"
+ ];
+
+ boot.extraModulePackages = [
+ config.boot.kernelPackages.broadcom_sta
+ ];
+
+ networking.wireless.enable = true;
+
+ nix = {
+ buildCores = 2;
+ maxJobs = 2;
+ daemonIONiceLevel = 1;
+ daemonNiceLevel = 1;
+ };
+
+ services.logind.extraConfig = ''
+ HandleHibernateKey=ignore
+ HandleLidSwitch=ignore
+ HandlePowerKey=ignore
+ HandleSuspendKey=ignore
+ '';
+
+ nixpkgs.config = {
+ allowUnfree = false;
+ allowUnfreePredicate = (x: pkgs.lib.hasPrefix "broadcom-sta-" x.name);
+ };
+}