summaryrefslogtreecommitdiffstats
path: root/tv/2configs/exim-smarthost.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-09-27 19:41:01 +0200
committermakefu <github@syntax-fehler.de>2015-09-27 19:41:01 +0200
commitbc2bd6e2f6e9295b14e641b82bff62b40641988d (patch)
tree8bc4b655c12b4e0bc33051116a3adb3003463d34 /tv/2configs/exim-smarthost.nix
parentc65614cdef66c38ff2939928e9072873e19e1c37 (diff)
parent170191034e51fb7e80ff6e6ddcac103ec7527afd (diff)
Merge branch 'before-merge'
Diffstat (limited to 'tv/2configs/exim-smarthost.nix')
-rw-r--r--tv/2configs/exim-smarthost.nix55
1 files changed, 55 insertions, 0 deletions
diff --git a/tv/2configs/exim-smarthost.nix b/tv/2configs/exim-smarthost.nix
new file mode 100644
index 00000000..811c8e4c
--- /dev/null
+++ b/tv/2configs/exim-smarthost.nix
@@ -0,0 +1,55 @@
+{ config, pkgs, ... }:
+
+{
+ krebs.exim-smarthost = {
+ enable = true;
+ primary_hostname = "${config.networking.hostName}.retiolum";
+ sender_domains = [
+ "shackspace.de"
+ "viljetic.de"
+ ];
+ relay_from_hosts = [
+ "10.243.13.37"
+ ];
+ internet-aliases = with config.krebs.users; [
+ { from = "tomislav@viljetic.de"; to = tv.mail; }
+
+ # (mindestens) lisp-stammtisch und elli haben die:
+ { from = "tv@viljetic.de"; to = tv.mail; }
+
+ { from = "tv@destroy.dyn.shackspace.de"; to = tv.mail; }
+
+ { from = "mirko@viljetic.de"; to = mv.mail; }
+
+ # TODO killme (wo wird die benutzt?)
+ { from = "tv@cd.retiolum"; to = tv.mail; }
+
+ # TODO lists@smtp.retiolum [consul]
+ { from = "postmaster@krebsco.de"; to = tv.mail; }
+
+ { from = "spam@krebsco.de";
+ to = pkgs.lib.concatStringsSep "," [
+ tv.mail
+ "lass@mors.retiolum"
+ makefu.mail
+ ];
+ }
+ ];
+ system-aliases = [
+ { from = "mailer-daemon"; to = "postmaster"; }
+ { from = "postmaster"; to = "root"; }
+ { from = "nobody"; to = "root"; }
+ { from = "hostmaster"; to = "root"; }
+ { from = "usenet"; to = "root"; }
+ { from = "news"; to = "root"; }
+ { from = "webmaster"; to = "root"; }
+ { from = "www"; to = "root"; }
+ { from = "ftp"; to = "root"; }
+ { from = "abuse"; to = "root"; }
+ { from = "noc"; to = "root"; }
+ { from = "security"; to = "root"; }
+ { from = "root"; to = "tv"; }
+ { from = "mirko"; to = "mv"; }
+ ];
+ };
+}