summaryrefslogtreecommitdiffstats
path: root/tv/2configs/default.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2023-01-19 14:11:01 +0100
committerlassulus <lassulus@lassul.us>2023-01-19 14:11:01 +0100
commitb51998cfae7b6fe892f9f0f9a2c0ffcfeeded0ba (patch)
treeca76ec46d32a99edacfd2d0be19a7f1ef410fe76 /tv/2configs/default.nix
parent347bb9ae00f8f1b6942f94d4c983593052a5c227 (diff)
parent57abca263fe86259807e5597d1c8f11c3c3acd44 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/2configs/default.nix')
-rw-r--r--tv/2configs/default.nix21
1 files changed, 10 insertions, 11 deletions
diff --git a/tv/2configs/default.nix b/tv/2configs/default.nix
index 9babb92c..d1384845 100644
--- a/tv/2configs/default.nix
+++ b/tv/2configs/default.nix
@@ -16,6 +16,7 @@ with import ./lib;
./nets/hkw.nix
./networkd.nix
./nginx
+ ./nix.nix
./pki
./ssh.nix
./sshd.nix
@@ -45,20 +46,11 @@ with import ./lib;
}
{
- nix.extraOptions = ''
- auto-optimise-store = true
- '';
-
- # TODO check if both are required:
- nix.settings.extra-sandbox-paths = [
- "/etc/protocols"
- pkgs.iana-etc.outPath
- ];
- }
- {
nixpkgs.config.allowUnfree = false;
}
{
+ environment.homeBinInPath = true;
+
environment.profileRelativeEnvVars.PATH = mkForce [ "/bin" ];
environment.systemPackages = with pkgs; [
@@ -137,4 +129,11 @@ with import ./lib;
];
}
];
+
+ nixpkgs.overlays =
+ mkAfter (optional config.hardware.video.hidpi.enable (self: super: {
+ alacritty-tv = super.alacritty-tv.override {
+ variant = "hidpi";
+ };
+ }));
}