summaryrefslogtreecommitdiffstats
path: root/tv/2configs/binary-cache/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-11-25 00:19:17 +0100
committerlassulus <lass@aidsballs.de>2016-11-25 00:19:17 +0100
commit8014aa6594a6bb442a950abed67dd13543d34d88 (patch)
tree101817d3948442b5294f1f23543a7ac9df9f0ddd /tv/2configs/binary-cache/default.nix
parent2ea9b739ac64773de0a490736d6e1bdf556c6b60 (diff)
parentb3c6e9a2bde5d1c911d1bb17ca3218acab7285b8 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'tv/2configs/binary-cache/default.nix')
-rw-r--r--tv/2configs/binary-cache/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/tv/2configs/binary-cache/default.nix b/tv/2configs/binary-cache/default.nix
new file mode 100644
index 00000000..5902f189
--- /dev/null
+++ b/tv/2configs/binary-cache/default.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, ... }: with import <stockholm/lib>;
+{
+ environment.etc."binary-cache.pubkey".text =
+ config.krebs.build.host.binary-cache.pubkey;
+
+ services.nix-serve = {
+ enable = true;
+ secretKeyFile = config.krebs.secret.files.binary-cache-seckey.path;
+ };
+
+ systemd.services.nix-serve = {
+ requires = ["secret.service"];
+ after = ["secret.service"];
+ };
+
+ krebs.secret.files.binary-cache-seckey = {
+ path = "/run/secret/nix-serve.key";
+ owner.name = "nix-serve";
+ source-path = toString <secrets> + "/nix-serve.key";
+ };
+
+ krebs.nginx = {
+ enable = true;
+ servers.nix-serve = {
+ server-names = [
+ "cache.${config.krebs.build.host.name}.gg23"
+ ];
+ locations = singleton (nameValuePair "/" ''
+ proxy_pass http://localhost:${toString config.services.nix-serve.port};
+ '');
+ };
+ };
+}