summaryrefslogtreecommitdiffstats
path: root/tv/2configs/bash.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2016-07-23 19:21:23 +0200
committerlassulus <lass@aidsballs.de>2016-07-23 19:21:23 +0200
commitf978c5312e1f88dd936495ff0fcd3a3aa032d90f (patch)
tree56e10a2cf4ced3d18d4ee8bfd4ba066e42a079d2 /tv/2configs/bash.nix
parent29ef105c46287bb9964269004a56c51d4a2834bd (diff)
parentc546bc8c2dc1ec0fa120c79df3de4d977ce322ed (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'tv/2configs/bash.nix')
-rw-r--r--tv/2configs/bash.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/tv/2configs/bash.nix b/tv/2configs/bash.nix
new file mode 100644
index 00000000..fe87aa8d
--- /dev/null
+++ b/tv/2configs/bash.nix
@@ -0,0 +1,37 @@
+{ config, lib, pkgs, ... }:
+
+with config.krebs.lib;
+
+{
+ programs.bash = {
+ interactiveShellInit = ''
+ HISTCONTROL='erasedups:ignorespace'
+ HISTSIZE=65536
+ HISTFILESIZE=$HISTSIZE
+
+ shopt -s checkhash
+ shopt -s histappend histreedit histverify
+ shopt -s no_empty_cmd_completion
+ complete -d cd
+ '';
+ promptInit = ''
+ case $UID in
+ 0)
+ PS1='\[\e[1;31m\]\w\[\e[0m\] '
+ ;;
+ ${toString config.krebs.build.user.uid})
+ PS1='\[\e[1;32m\]\w\[\e[0m\] '
+ ;;
+ *)
+ PS1='\[\e[1;35m\]\u \[\e[1;32m\]\w\[\e[0m\] '
+ ;;
+ esac
+ if test -n "$SSH_CLIENT"; then
+ PS1='\[\e[35m\]\h'" $PS1"
+ fi
+ if test -n "$SSH_AGENT_PID"; then
+ PS1="ssh-agent[$SSH_AGENT_PID] $PS1"
+ fi
+ '';
+ };
+}