summaryrefslogtreecommitdiffstats
path: root/shared/2configs/repo-sync.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-15 18:52:05 +0100
committertv <tv@krebsco.de>2016-02-15 18:52:05 +0100
commit43ed24ed66ac1f16ece9199b7b4b41c26ca0b91d (patch)
tree3d1f15c8fc01bbc56ebfe547ae86c0fb40de8eda /shared/2configs/repo-sync.nix
parentea910d7d99ec0d36f7f0cc07566dc82ea16f02ca (diff)
parenta94a4c42065fb2fd489a03fd7b0db60ebabb8ebf (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'shared/2configs/repo-sync.nix')
-rw-r--r--shared/2configs/repo-sync.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/shared/2configs/repo-sync.nix b/shared/2configs/repo-sync.nix
new file mode 100644
index 00000000..b23cb167
--- /dev/null
+++ b/shared/2configs/repo-sync.nix
@@ -0,0 +1,28 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+{
+ krebs.repo-sync = let
+ # TODO addMirrorURL function
+ mirror = "git@wolf:stockholm-mirror";
+ in {
+ enable = true;
+ config = {
+ makefu = {
+ origin.url = http://cgit.gum/stockholm ;
+ mirror.url = mirror;
+ };
+ tv = {
+ origin.url = http://cgit.cd/stockholm ;
+ mirror.url = mirror;
+ };
+ lassulus = {
+ origin.url = http://cgit.cloudkrebs/stockholm ;
+ mirror.url = mirror;
+ };
+ "@latest" = {
+ mirror.url = mirror;
+ };
+ };
+ };
+}