summaryrefslogtreecommitdiffstats
path: root/shared/1systems/test-arch.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-11-14 01:51:36 +0100
committermakefu <github@syntax-fehler.de>2015-11-14 01:51:36 +0100
commit773a67a983cbe1928da6c524db24a25229a6f5fe (patch)
tree2a00ed5a39f85b837578625cf49d193f4d308f14 /shared/1systems/test-arch.nix
parenta0fbe917ac45cda4de0f16bced3ce3ebfc556fe8 (diff)
parente7d22252dcad25fd5594e9a431f5a39aa620906d (diff)
Merge remote-tracking branch 'cloudkrebs/master' into pre-merge
Diffstat (limited to 'shared/1systems/test-arch.nix')
-rw-r--r--shared/1systems/test-arch.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/shared/1systems/test-arch.nix b/shared/1systems/test-arch.nix
new file mode 100644
index 00000000..ece20949
--- /dev/null
+++ b/shared/1systems/test-arch.nix
@@ -0,0 +1,32 @@
+{ config, pkgs, ... }:
+
+{
+ imports = [
+ ../2configs/base.nix
+ {
+ boot.loader.grub = {
+ device = "/dev/sda";
+ splashImage = null;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "ata_piix"
+ "vmw_pvscsi"
+ ];
+
+ fileSystems."/" = {
+ device = "/dev/sda1";
+ };
+ }
+ {
+ networking.dhcpcd.allowInterfaces = [
+ "enp*"
+ ];
+ }
+ {
+ sound.enable = false;
+ }
+ ];
+
+ krebs.build.host = config.krebs.hosts.test-arch;
+}