summaryrefslogtreecommitdiffstats
path: root/nin/2configs/ableton.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-02-28 20:22:08 +0000
committerjeschli <jeschli@gmail.com>2018-02-28 20:22:08 +0000
commite7ac3fc703929cd503bc6a01cad449a5b2c328f2 (patch)
treea03346a78c60212faa190f4d9ae146ef5a2d6324 /nin/2configs/ableton.nix
parenta7e49dd5fc590ba2ccb26d559d672767c87a7692 (diff)
parent793742b9d1b2eab942e5d06ed27028c636cda583 (diff)
Merge branch 'staging/jeschli' of prism.i:stockholm into staging/jeschli
Diffstat (limited to 'nin/2configs/ableton.nix')
-rw-r--r--nin/2configs/ableton.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/nin/2configs/ableton.nix b/nin/2configs/ableton.nix
new file mode 100644
index 00000000..343a9089
--- /dev/null
+++ b/nin/2configs/ableton.nix
@@ -0,0 +1,20 @@
+{ config, pkgs, ... }: let
+ mainUser = config.users.extraUsers.nin;
+in {
+ users.users= {
+ ableton = {
+ isNormalUser = true;
+ extraGroups = [
+ "audio"
+ "video"
+ ];
+ packages = [
+ pkgs.wine
+ pkgs.winetricks
+ ];
+ };
+ };
+ security.sudo.extraConfig = ''
+ ${mainUser.name} ALL=(ableton) NOPASSWD: ALL
+ '';
+}