summaryrefslogtreecommitdiffstats
path: root/modules/tv/base.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-04-08 01:07:01 +0200
committertv <tv@shackspace.de>2015-05-19 23:16:56 +0200
commitcd6374e641420ade3603f0fd23fe9afac5c443bc (patch)
tree14dd49072264f70f32d826fadc3489a7b101b62c /modules/tv/base.nix
parent6e70d8fc47f0725a63dc92c1c43d2b1831c7c4ef (diff)
I Like To Move It
Diffstat (limited to 'modules/tv/base.nix')
-rw-r--r--modules/tv/base.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/tv/base.nix b/modules/tv/base.nix
new file mode 100644
index 00000000..76c8b897
--- /dev/null
+++ b/modules/tv/base.nix
@@ -0,0 +1,17 @@
+{ config, pkgs, ... }:
+
+{
+ time.timeZone = "Europe/Berlin";
+
+ nix.maxJobs = 8;
+ nix.useChroot = true;
+ # TODO check if both are required:
+ nix.chrootDirs = [ "/etc/protocols" pkgs.iana_etc.outPath ];
+
+ nix.trustedBinaryCaches = [
+ "https://cache.nixos.org"
+ "http://cache.nixos.org"
+ "http://hydra.nixos.org"
+ ];
+
+}