summaryrefslogtreecommitdiffstats
path: root/modules/rmdir/users.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-19 22:06:24 +0200
committertv <tv@shackspace.de>2015-06-19 22:06:24 +0200
commit1538630782ac8c56d549af4fcac4c9abcba8c9c5 (patch)
tree35279433e44979ad8c240d3b5bba625702659044 /modules/rmdir/users.nix
parente5b14a9ed69a75f57a2184f85f5b4f24cb50da51 (diff)
host rmdir: initial commit
Diffstat (limited to 'modules/rmdir/users.nix')
-rw-r--r--modules/rmdir/users.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/modules/rmdir/users.nix b/modules/rmdir/users.nix
new file mode 100644
index 00000000..82f078b4
--- /dev/null
+++ b/modules/rmdir/users.nix
@@ -0,0 +1,19 @@
+{ ... }:
+
+let
+ inherit (builtins) readFile;
+in
+
+{
+ users.extraUsers =
+ {
+ root = {
+ openssh.authorizedKeys.keys = [
+ (readFile <pubkeys/deploy_wu.ssh.pub>)
+ (readFile <pubkeys/tv_wu.ssh.pub>)
+ ];
+ };
+ };
+
+ users.mutableUsers = false;
+}