summaryrefslogtreecommitdiffstats
path: root/modules/cd/git.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-18 23:59:14 +0200
committertv <tv@shackspace.de>2015-06-19 00:01:09 +0200
commitca7048e27cfdc354dd0fdf17e971548cb0adbba9 (patch)
tree860eb925ed4989d9b3af3368418e67db79ccfbb6 /modules/cd/git.nix
parent313fe868aa6f1334cbb130f8eb4ec748391813c3 (diff)
host cd: move git config to separate file
Diffstat (limited to 'modules/cd/git.nix')
-rw-r--r--modules/cd/git.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/modules/cd/git.nix b/modules/cd/git.nix
new file mode 100644
index 00000000..88d4968a
--- /dev/null
+++ b/modules/cd/git.nix
@@ -0,0 +1,59 @@
+{ config, lib, pkgs, ... }:
+
+let
+ inherit (builtins) readFile;
+ # TODO lib should already include our stuff
+ inherit (import ../../lib { inherit lib pkgs; }) addNames git;
+in
+
+{
+ imports = [
+ ../tv/git
+ ];
+
+ services.git = rec {
+ enable = true;
+
+ users = addNames {
+ tv = { pubkey = readFile <pubkeys/tv.ssh.pub>; };
+ lass = { pubkey = "xxx"; };
+ makefu = { pubkey = "xxx"; };
+ };
+
+ repos = addNames {
+ shitment = {
+ desc = "shitment repository";
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
+ };
+ };
+ public = true;
+ };
+ testing = {
+ desc = "testing repository";
+ hooks = {
+ post-receive = git.irc-announce {
+ nick = config.networking.hostName; # TODO make this the default
+ channel = "#retiolum";
+ server = "ire.retiolum";
+ };
+ };
+ public = true;
+ };
+ };
+
+ rules = with git; with users; with repos; [
+ { user = tv;
+ repo = [ testing shitment ];
+ perm = push "refs/*" [ non-fast-forward create delete merge ];
+ }
+ { user = [ lass makefu ];
+ repo = [ testing shitment ];
+ perm = fetch;
+ }
+ ];
+ };
+}