summaryrefslogtreecommitdiffstats
path: root/mb/3modules/hosts.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2019-04-28 15:05:34 +0200
committerjeschli <jeschli@gmail.com>2019-04-28 15:05:34 +0200
commite45b3492b3961685936378a160adb225789e51d9 (patch)
treecc0480e485ab78d1f52f80ec36987b9a57e925f7 /mb/3modules/hosts.nix
parent97d4f9a771a9bbb1b45085569028db2d7dfbd610 (diff)
parent915e4b843790d3e71bdccea124d4832ca042e456 (diff)
Merge branch 'master' of prism.r:stockholm
Diffstat (limited to 'mb/3modules/hosts.nix')
-rw-r--r--mb/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/mb/3modules/hosts.nix b/mb/3modules/hosts.nix
new file mode 100644
index 00000000..5dc9b5ca
--- /dev/null
+++ b/mb/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with import <stockholm/lib>;
+
+{
+ options.mb.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "mb" && host.ci)
+ config.krebs.hosts;
+ };
+}