summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/qcma/default.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-10-13 20:33:45 +0200
committertv <tv@krebsco.de>2016-10-13 20:33:45 +0200
commit65165f422d8e08f29ec269a3ce98e7ebfa22c622 (patch)
tree13d15f63626129c439840a4b406e3fe4e693096f /makefu/5pkgs/qcma/default.nix
parent38d26c551cf3c53151120646a893a13990b21c5c (diff)
parent8458ffd7a00a3e4c734755de7d72f95458d1bb52 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'makefu/5pkgs/qcma/default.nix')
-rw-r--r--makefu/5pkgs/qcma/default.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/makefu/5pkgs/qcma/default.nix b/makefu/5pkgs/qcma/default.nix
new file mode 100644
index 00000000..6eb1a971
--- /dev/null
+++ b/makefu/5pkgs/qcma/default.nix
@@ -0,0 +1,64 @@
+{ lib, stdenv, fetchFromGitHub, fetchgit, libusb, libtool, autoconf, pkgconfig, git,
+gettext, automake, libxml2 , qmakeHook, makeQtWrapper,
+qtbase, qttools, qtmultimedia, libnotify, ffmpeg, gdk_pixbuf }:
+let
+ libvitamtp = stdenv.mkDerivation rec {
+ name = "libvitamtp-${version}";
+ version = "2.5.9";
+
+ src = fetchFromGitHub {
+ owner = "codestation";
+ repo = "vitamtp";
+ rev = "v"+version;
+ sha256 = "09c9f7gqpyicfpnhrfb4r67s2hci6hh31bzmqlpds4fywv5mzaf8";
+ };
+
+ buildInputs = [ libusb libxml2 libtool autoconf automake gettext pkgconfig ];
+ preConfigure = "sh ./autogen.sh";
+
+ meta = {
+ description = "Content Manager Assistant for the PS Vita";
+ homepage = https://github.com/codestation/qcma;
+ license = stdenv.lib.licenses.gpl2;
+ platforms = stdenv.lib.platforms.linux;
+ maintainers = with stdenv.lib.maintainers; [ makefu ];
+ };
+ };
+in stdenv.mkDerivation rec {
+ name = "qcma-${version}";
+ version = "0.3.13";
+
+ src = fetchgit {
+ url = "git://github.com/codestation/qcma.git";
+ rev = "refs/tags/v"+version;
+ leaveDotGit = true;
+ sha256 = "164abjwlw2nw2i30wlwpsavz1zjkp6a14yprvinma5hflkw4yj6i";
+ };
+
+ preConfigure = ''
+ lrelease common/resources/translations/*.ts
+ '';
+
+ # TODO: manually adding qtbase and qtmultimedia to the library path is shit,
+ # this should be done somewhere before when building the project, idk.
+ installPhase = ''
+ make INSTALL_ROOT="$(out)" install
+ for i in qcma qcma_cli; do
+ wrapQtProgram $out/bin/$i --prefix LD_LIBRARY_PATH : ${lib.makeLibraryPath [
+ qtbase qtmultimedia ]}
+ done
+ '';
+
+ enableParallelBuilding = true;
+
+ buildInputs = [ gdk_pixbuf ffmpeg libnotify libvitamtp git qtmultimedia qtbase ];
+ nativeBuildInputs = [ qmakeHook qttools pkgconfig makeQtWrapper ];
+
+ meta = {
+ description = "Content Manager Assistant for the PS Vita";
+ homepage = https://github.com/codestation/qcma;
+ license = stdenv.lib.licenses.gpl2;
+ platforms = stdenv.lib.platforms.linux;
+ maintainers = with stdenv.lib.maintainers; [ makefu ];
+ };
+}