summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/python-firetv/default.nix
diff options
context:
space:
mode:
authornin <nin@c-base.org>2018-05-02 15:13:40 +0200
committernin <nin@c-base.org>2018-05-02 15:13:40 +0200
commit689fb1a77ad53722086da922de2de533460205b3 (patch)
tree408667e6aa15e1e0fa031e99c003c3968ba1578d /makefu/5pkgs/python-firetv/default.nix
parent702136442c5f8c4f7f1bb911bd21d238a164218a (diff)
parent37fa7bff9339799984554b8ccbacf1f07281d6ce (diff)
Merge branch 'master' of prism:stockholm
Diffstat (limited to 'makefu/5pkgs/python-firetv/default.nix')
-rw-r--r--makefu/5pkgs/python-firetv/default.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/makefu/5pkgs/python-firetv/default.nix b/makefu/5pkgs/python-firetv/default.nix
new file mode 100644
index 00000000..1fb772f1
--- /dev/null
+++ b/makefu/5pkgs/python-firetv/default.nix
@@ -0,0 +1,40 @@
+{ lib, pkgs, python2Packages, ... }:
+# requires libusb1 from unstable
+with (import <nixpkgs-unstable> {}).python2Packages; let
+
+ python-adb = buildPythonPackage rec {
+ pname = "adb";
+ version = "1.2.0";
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "0v4my47ikgkbq04gdllpx6kql5cfh7dnpq2fk72x03z74mqri7v8";
+ };
+
+ propagatedBuildInputs = [ libusb1 m2crypto ];
+ meta = {
+ homepage = https://github.com/google/python-adb;
+ description = "Python ADB + Fastboot implementation";
+ license = lib.licenses.asl20;
+ };
+ };
+in
+ buildPythonPackage rec {
+ name = "python-firetv-${version}";
+ version = "1.0.5";
+
+ src = pkgs.fetchFromGitHub {
+ owner = "happyleavesaoc";
+ repo = "python-firetv";
+ # rev = version;
+ rev = "55406c6";
+ sha256 = "1r2yighilchs0jvcvbngkjxkk7gp588ikcl64x7afqzxc6zxv7wp";
+ };
+
+ propagatedBuildInputs = [ python-adb flask pyyaml ];
+ meta = {
+ homepage = https://github.com/happyleavesaoc/python-firetv;
+ description = "provides state informations and some control of an amazon firetv";
+ license = lib.licenses.mit;
+ };
+}