summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/pfsshell/default.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-02-18 10:48:18 +0100
committerjeschli <jeschli@gmail.com>2018-02-18 10:48:18 +0100
commit52b846c98b21f19c2a138361191439c487fc87cc (patch)
treec5182446981dd14df8da4060148980af9e27f08a /makefu/5pkgs/pfsshell/default.nix
parent94c59247d13622b0293be54cdb5893526434f5d1 (diff)
parent13e289a69d1c901e6f1a044ce8973433e9e43880 (diff)
Merge branch 'master' of prism.r:stockholm into staging/jeschli
Diffstat (limited to 'makefu/5pkgs/pfsshell/default.nix')
-rw-r--r--makefu/5pkgs/pfsshell/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/makefu/5pkgs/pfsshell/default.nix b/makefu/5pkgs/pfsshell/default.nix
new file mode 100644
index 00000000..fc6b3706
--- /dev/null
+++ b/makefu/5pkgs/pfsshell/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, lib, pkgs, fetchurl,fetchFromGitHub, upx, wine }:
+stdenv.mkDerivation rec {
+ pname = "pfsshell";
+ version = "64f8c2";
+ name = "${pname}-${version}";
+
+ src = fetchFromGitHub {
+ owner = "makefu";
+ repo = "pfsshell";
+ rev = version;
+ sha256 = "01lbqf8s91p8id58xa16fp555i03vfycqvhv7qzpnrjy6yvp9dm8";
+ };
+
+ buildInputs = [ ];
+
+ makeFlags = [ ];
+
+ installPhase = ''
+ mkdir -p $out/bin
+ cp pfsshell $out/bin
+ '';
+
+ meta = {
+ homepage = https://github.com/uyjulian/pfsshell ;
+ description = "browse and transfer files to/from PFS filesystems";
+ };
+}