summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/libcoap/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-05-02 14:14:55 +0200
committerlassulus <lass@lassul.us>2017-05-02 14:14:55 +0200
commitdd4439bfc840e61f2b3f1004e74226854d5a378a (patch)
tree136983c641ca3288c126c52acea1d3398534c163 /makefu/5pkgs/libcoap/default.nix
parent7e1516cc0de48c169a27a07f43930b940d6a9004 (diff)
parent22188f14d3e4eb309fba69a65049cb2c1ec05e2d (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/5pkgs/libcoap/default.nix')
-rw-r--r--makefu/5pkgs/libcoap/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/makefu/5pkgs/libcoap/default.nix b/makefu/5pkgs/libcoap/default.nix
new file mode 100644
index 00000000..7e8d03ed
--- /dev/null
+++ b/makefu/5pkgs/libcoap/default.nix
@@ -0,0 +1,27 @@
+{ lib, stdenv, fetchFromGitHub, autoreconfHook, autoconf-archive, pkgconfig,
+gettext, asciidoc, doxygen, libxml2, libxslt, docbook_xsl, ... }:
+stdenv.mkDerivation rec {
+ name = "libcoap-${version}";
+ version = "4.1.2";
+
+ src = fetchFromGitHub {
+ owner = "obgm";
+ repo = "libcoap";
+ rev = "v${version}";
+ sha256 = "0f0qq15480ja1s03vn8lzw4b3mzdgy46hng4aigi6i6qbzf29kf5";
+ };
+
+ patchPhase = ''
+ sed -i 's/$(A2X)/& --no-xmllint/' examples/Makefile.am
+ '';
+ buildInputs = [ gettext asciidoc doxygen libxml2.bin libxslt docbook_xsl];
+ nativeBuildInputs = [ autoreconfHook autoconf-archive pkgconfig ];
+
+ meta = {
+ description = "";
+ homepage = http://coap.technology;
+ license = stdenv.lib.licenses.gpl2;
+ platforms = stdenv.lib.platforms.linux;
+ maintainers = with stdenv.lib.maintainers; [ makefu ];
+ };
+}