summaryrefslogtreecommitdiffstats
path: root/makefu/5pkgs/devpi/py3-fix-encoding.patch
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-10-20 20:22:29 +0200
committertv <tv@krebsco.de>2016-10-20 20:22:29 +0200
commit9329c1e47ddda0653d7e9824a01632ce3766e8f0 (patch)
tree2bfb70737a757d0bd61ca0aa895c77d740b21e73 /makefu/5pkgs/devpi/py3-fix-encoding.patch
parent844d347ce7cf0b7646e9ecba3fbdc0b90e608501 (diff)
parent0f2a9778315c3126794c0f1ad63710d38e7a67f7 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'makefu/5pkgs/devpi/py3-fix-encoding.patch')
-rw-r--r--makefu/5pkgs/devpi/py3-fix-encoding.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/makefu/5pkgs/devpi/py3-fix-encoding.patch b/makefu/5pkgs/devpi/py3-fix-encoding.patch
new file mode 100644
index 00000000..e5f94069
--- /dev/null
+++ b/makefu/5pkgs/devpi/py3-fix-encoding.patch
@@ -0,0 +1,11 @@
++++ a/setup.py
+--- b/setup.py
+@@ -26,7 +26,7 @@
+
+
+ def get_changelog():
+- text = open(os.path.join(here, 'CHANGELOG')).read()
++ text = open(os.path.join(here, 'CHANGELOG'),encoding='utf-8').read()
+ header_matches = list(re.finditer('^-+$', text, re.MULTILINE))
+ # until fifth header
+ text = text[:header_matches[5].start()]